Uncategorized

ili9341 lcd testing notes

Q: Rpi ILI9341 2.8″ 240 x 320 5110 SPI TFT LCD Screen Setup Problem

Dominic McGreevyI ordered a cheap 2.8 inch ILI9341 screen from Amazon (amazon.co.uk/…) in the hopes of using it in a custom handheld Retropie console. However, I have attempted many differ…

tlfong01

tlfong01
3071
Perhaps search this forum for “ili9341 tlfong01”.
I read the product datasheet and found that it has no touch screen option. So it should be easier to use: Ref (1) “Amazon Ftvogue ILI9341 2.8″ 240×320 SPI TFT LCD Screen (5110 interface, with SD Card socket, no touch screen)”: amazon.co.uk/240×320-Screen-Serial-Module-ILI9341/dp/B07MXH9‌​2RL/…. Good Luck. Cheers.
Your screen is [Nokia 5110] compatible TFT LCD screen. So you might find the following driver worth a try: (1) “5110 and TFT LCD video tutorial – ElecFreaks”: elecfreaks.com/store/blog/post/…, (2) “YouTube 5110 LCD and TFT LCD (TFT01-1.8SP and 2.2SP)”: youtube.com/watch?v=N7HGZuwRrp4&feature=youtu.be. Good Luck. Cheers.
Dominic McGreevy

Dominic McGreevy
11
Thank you for your input! I searched “ili9341 tlfong01” and went to the link you shared (pi0cket.com/ili9341-raspberry-pi-guide). This was the most luck that I have had so far; for the most part, it looks as though the terminal is processing it correctly. However, there is still nothing being displayed on the screen. Instead I get this error message: “-bash: nbsp: command not found”. This confuses me as, when I type in “confbmap 1 1”, it outputs: “[1]+ Done sudo modprobe fbtft_device custom name=fb_ili9341”. Many thanks, Dominic.
tlfong01

tlfong01
3071
Ah, I think you have the character encoding problem. See the following Q&A for more details: (1) “What is this character (Â) and how do I remove it with PHP? – Asked 8 years ago, Viewed 36k times”: stackoverflow.com/questions/7186550/…
Don’t worry if you don’t understand what those web page guys are talking about. What you need to know is to get rid of the funny characters in the following string of your long bash command: “custom name=fb_ili934 ”. You might like to ask/google around what is the meaning of the string “ ” I forgot if “ ” means blank/space or similar. If you are too lazy to google, you might just try and error as “ili9341” followed by a space and semicolon or command. Good luck and cheers.
I googled again: “A common character entity used in HTML is the non-breaking space:  ”: w3schools.com/html/html_entities.asp. Cheers. PS – Now I remember those funny characters which I did use ages ago, when I was learning HTML!
Dominic McGreevy
Dominic McGreevy
Once again, thank you very much! I am no longer just seeing a white backlight and I’m seeing a black screen with the backlight on. Finally some progress! I still don’t understand why it isn’t outputting the Retropie UI. Many thanks, Dominic.
tlfong01

tlfong01
Congratulations! So you are making some progress. I have no idea of your black screen problem, properly wrong driver. I forgot if you need to compile the driver. Have you done that! Perhaps I can read the pi0cket article more carefully and see anything wrong. Keep trying. Cheers.
Dominic McGreevy
Dominic McGreevy
0:32
Hi again! I don’t think that this is a driver issue as it is filling the screen with black, meaning that it is doing something. I just don’t know how to fix it. It’s really strange because it’s not an uncommon thing to use an ILI9341 screen with a Raspberry Pi, yet I seem to be running into all sorts of issues which nobody else is.
tlfong01

tlfong01
I didn’t catch you. Are you saying that Rpi ILI9341 is a piece of cake, but you can’t fix it. If you don’t find any guy showing off their working thing, that means all others are weeping in the dark. Perhaps I should resume my long stalled LCD project: raspberrypi.stackexchange.com/questions/104600/…. Cheers.
Dominic McGreevy
Dominic McGreevy
Sorry about that; I wasn’t clear. I was wondering whether it is because I’m doing it on a newer version of Retropie or something along those lines. I might have a go on an older version later and sew how it goes. Many thanks, Dominic.
tlfong01

tlfong01
Ah, actually it is not a good idea to start with Retropie, even your project is gaming. You might like to read Ref 11 ~14 for a better tutorial on setting up the ILI9341 screen, using notro/fbtft. This is what I suggest you to try instead. Ah, supper time. See you late this evening or tomorrow.
Dominic McGreevy

Dominic McGreevy
11
Hi. I installed Raspbian and attempted to do it on that instead of Retropie, yet I still haven’t had any luck. Unfortunately, I’m getting to the point where I want to give up because nothing is working. It’s causing me a lot of stress and I just don’t know whether it is worth it anymore. If you have managed to get a similar screen working, please can you tell me what operating system you used, how you wired it, what tutorial you used, etc. Many thanks, Dominic.
tlfong01

tlfong01
3071
Ah, your are using Orange Pi 2.0, uBuntu 14, of course won’t work. Me Rpi4B 4GB, buster 20feb13, and all my ili9341 screens are touch sensitive. Using no touch screens would damage my reputation, and I will be losing face when all my Arduino bad friends LOL. Ah, you remind me that I should have a couple of old, no touch LCDs in my junk box, collecting dust, including a Nokia 5110 screen. Let me search the box for any ugly ones that look like yours and give them a go. Perhaps you wait a little bit longer, and I will carry on till tomorrow, 🙂 youtube.com/watch?v=sC24GI9V_Cs
Dominic McGreevy
Dominic McGreevy
0:32
Thank yo so much! I don’t think you understand just how helpful you’ve been. I look forward to hearing from you again! Many thanks, Dominic.
By the way, I am using a Raspberry Pi 3B+ to test it but I will eventually use a Raspberry Pi Zero.
tlfong01

tlfong01
3071
Yes, you need to give as much details as possible, such as (1) Rpi version and raspbian version (buster 2020feb13)., (2) The wiring diagram you are using, (3) The instruction and steps you followed, at which step you get stuck, etc. You might like to read Appendix D as an example. I am not sure if the no touch LCD if found from the junk box, will have the same pin out as yours. Or it may happen that my touch sensitive LCD has pins more like yours.
It is likely that my wiring is different from yours. So I would suggest you to do this assignment to morrow: Edit your question, or post your own answer’ giving all the details, like my answer here.
And if you write up your answer, day after day, like me, as a diary or project progress report, then later when looking back (in case you do not give up in the middle :)), you would understand better every bit of the completed project, as you build it day after dayyoutube.com/watch?v=XonFZjuyc6E.Ah bed time. I call it a day, see you tomorrow.
17 hours later…
Dominic McGreevy
Dominic McGreevy
17:29
I’m using the Raspberry Pi 3B+ with Raspbian Buster (13 Feb 2020), I am using the instructions and wiring on pi0cket.com/… and I am getting stuck on “con2fbmap 1 1”.
3 hours later…
tlfong01
tlfong01
20:23
Thank you for your problem details. Let me try to repeat you steps in the pi0cket.com tutorial and see if I would also get stuck at the “con2famp 1 1” step. Cheers.
tlfong01

tlfong01
3071
20:44
I am testing the following module which I think looks like yours, most importantly your module pinout should be exactly or almost exactly like mine, so that we can use the same wiring cable. Now I am uploading my module. Can you also upload yours, just to make sure that we can compare and contrast later. BTW, do you have any multimeter in hand to do troubleshooting later?
user image
BTW, the pio0cket.com link you mentioned above is broken. Can you confirm if it is OK?
Anyway, now I am going to make a interface cable. I will show you later. You need to be very careful to make sure the SPI and GPIO pins are correct, otherwise you cannot setup the module properly and will get only a black or white screen. It would be nice if you can show me a photo of the wiring you are using in the test.
just now I checked pi0cket.com again and got the following error message: “pi0cket.com refused to connect. Try: Checking the connection Checking the proxy and the firewall”. Please confirm if you either can connect to pi0cket.com.
tlfong01

tlfong01
3071
21:10
The pi0cket.com link is still broken, so I googled to find a replacement. I found the following looking good. So I will give it a go. You might like to read the tutorial and join in. (1) Operate 2.2 “SPI-Display (ILI9341) on the Raspberry – Xgadget
xgadget.de/anleitung/…

(2) TFT SPI-Display (ILI9341) on the Raspberry Pi – Xgadget
youtube.com/…

tlfong01

tlfong01
3071
21:24
I found Xgadget’s tutorial seems better thatn pi0cket. So I will forget pi0cket and go for Xgadget. Below is the cable I am going to assemble.
user image
tlfong01

Categories: Uncategorized

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.